Для pthreads требуется сборка PHP с включенным ZTS (Zend Thread Safety) (--enable-keeper-zts или --enable-zts в Windows)

Предостережение

Zend Thread Safety не может быть включен после сборки; это вариант конфигурации во время сборки.

pthreads следует собирать везде, где есть рабочий заголовок Posix Threads (pthread.h) и сборка PHP ZTS, включая Windows (с использованием проекта pthread-w32 из redhat).

Никаких мыслей по поводу “Требования ”